TED: The Energy Detective from Energy, Inc. A Complete Waste of Money

A client of mine recently purchase a TED, The Energy Detective, 5000 series device with which to monitor his house’s power consumption. This thing is a complete piece of garbage, fails to display any useful data more than half of the time (yes, we’ve been keeping track), and their technical support is rude, uninterested and completely unhelpful. In summary, don’t waste your money. The TED 5000 has two main components: parts that connect directly into your home’s power lines to measure energy usage, and an Ethernet gateway to display this information. They also include a little desktop unit to display summary information, and that part appears to work fine. However, to get the nitty-gritty details, you need to use the web interface or configure your TED to send its information to Google Powermeter.

On our first call to TED technical support, when we weren’t able to get any useful data from the transmitter, we were asked if there are any X10 devices in the house (which there are) and if there are any compact fluorescent bulbs in use. Both of these devices cause problems with TED. Excuse me? TED doesn’t work if you have compact fluorescent bulbs? As common as they are now, that’s like saying TED doesn’t work if you have the lights on! As for X10, my client also had those and so the electrician had to wire up a separate circuit on which to run the TED equipment. After this, we started getting data from the device… sometimes.

LOADING....I say “sometimes” because a majority of the time, the TED web interface simply hangs at a big gray screen simply saying “LOADING….” Often that’s all you get. Sometimes you get a little more, like a half-loaded page of dials and energy readouts, but usually not. Rarely, you can actually get the complete TED GUI, but again, more times than not, this is not the case.

So what did we do? Called TED technical support. Right off the bat, the people we spoke with came across as disinterested and unhelpful. A particular tech was a great example of this. Here’s a rough transcript of a conversation I had with him while trying to get the TED to upload its information to Google Powermeter:

Me: “Hi. I have a TED 5000 and I’m trying to connect it to Google Powermeter.”

TED: “Read the instructions.”

Me (after a short pause): “I have. And it’s not working.”

TED: “Well it’s a problem with Google Powermeter.”

After several attempts at prying more information from TED, and failing to get any responses other than “read the instructions,” “read the forums and mailing lists,” and “TED doesn’t print error messages, Google Powermeter sends error messages” (this was in response to a message from the TED web server saying “Unable to connect to Google Powermeter”), I gave up and ended the call.

I called back a few minutes later, and spoke with this tech’s manager. He appeared concerned, but was unable to give me any more technical assistance than I didn’t get from the previous tech, stating that he was “not a network expert” and “it’s usually a DNS problem.” I didn’t bother explaining that I am a network expert, and it’s not a DNS problem. When he gave me his email and asked that I email him a description of the problem, which I did, so he could forward it to their development engineers. Here’s a copy of the email I sent:

Dear XXXX,

This is a followup to our phone conversation. As I explained, I am an IT consultant attempting to connect a TED 5000 to Google Powermeter.

First, regardless of what connection we use (Ethernet, wireless, or external connection through our router via Comcast Cable), the web interface on the device is always very sluggish, and half the time (no exaggeration) the complete web page does not even load, regardless of what connection we’re using. A brief search on the Internet would seem to indicate that this is a common problem, so perhaps I should stop right there and try to get it addressed first.

When we attempted to register this unit with Google Powermeter from a remote site, it failed, as we were redirected to its private IP address. To address this, I came on site to try activating Google Powermeter locally. However, now when I am referred back to the private IP from Google Powermeter, the TED displays an error message simply stating “there was an error connecting to Google Powermeter.”

Although the unit has a private IP address and, when it’s responding, we have no trouble accessing it from outside of the private network, over the Internet, or using the Ted-o-Meter iPhone app.

The unit is running on a non-standard port (8081), but we can change that to standard port 443 if required.

What I am looking for is someone who knows the answers to these questions so I don’t have to do so much guesswork on my client’s bill. I do not think my questions are overly complex, but as I told you on the phone, I was denied any sort of help other than “go read the forums” and “read the instructions.”

Thank you for your attention.

Regards,

Peter

That was eight days ago. Here’s the response I got:

That’s right. Nothing.

I tried to upgrade the firmware, but before I can do that, I need to see what version is currently installed and, of course, that would require actually being able to connect to the unit in the first place.

Conclusion: Don’t waste your money.

Leave a Reply